立足山东,服务全国,做有智慧的IDC!

服务热线:0632-7560000

关于我们 信息中心 法律申明 支付方式 加入我们 联系我们

关于“Linux底层函数库glibc出现重大安全漏洞”公告

新闻发布:香港服务器   发布时间:2021-01-11 11:21

尊敬的用户:

您好!

外界安全研究人员发现:Linux底层函数库glibc再现重大安全漏洞。

漏洞成因在于glibc中处理DNS查询的代码存在栈溢出漏洞,远端攻击者可以通过DNS服务回应特定构造的DNS响应数据包,造成风险。

 [受影响系统]

CentOS6 所有版本

CentOS7 所有版本

SUSE Linux Enterprise Server 11 SP3

SUSE Linux Enterprise Server 12

Ubuntu Server 14.04.1 LTS 32位

Ubuntu Server 14.04.1 LTS 64位

Ubuntu Server 12.04 LTS 64位

Debian 

 [漏洞编号]

CVE-2015-7547

 [漏洞修复方法]

根据系统发行版,按照如下更新glibc之后,请务必确定发行版对应glibc的版本,建议在更新后重启系统。

 CentOS系统

官方说明链接:https://www.linuxos.pro/cve-2015-7547-linux-glibc-bug-vulnerability/

centos 5.10:不受影响

centos 5.8:不受影响

centos 6.X:需要升级到版本: >= glibc-2.12-1.166.el6_7.7

centos 7.X:需要升级到版本:>= glibc-2.17-106.el7_2.4

步骤:

1. 同步源: yum makecache

2. 升级 glib: yum update glibc

3. 检查版本:rpm -q glibc

 Debian系统

官方说明链接:https://security-tracker.debian.org/tracker/CVE-2015-7547

debian 6:需要升级 libc6 到  >= 2.11.3-4+deb6u11

debian 7:需要升级 libc6 到 >= 2.13-38+deb7u10

步骤:

1. 检查 libc6 版本: dpkg -l libc6

2. 对于 debian7,注意需要添加安全补丁源

2. 同步源:apt-get update

3. 升级 libc6:apt-get install libc6

4. 再次检查 libc6 版本:dpkg -l libc6

 ubuntu系统

官方说明链接:http://www.ubuntu.com/usn/usn-2900-1/

ubuntu 12:需要升级 libc6 到 >= 2.15-0ubuntu10.13

ubuntu 14:需要升级 libc6 到 >= 2.19-0ubuntu6.7

1. 检查 libc6 版本:dpkg -l libc6

2. 同步源:apt-get update

3. 升级 libc6 包:apt-get install libc6

4. 再次验证 libc6 版本:dpkg -l libc6